Window/Door Placement in 24.0.0

I recently updated to 24.0.0, not sure if it’s a bug or what, but I can’t place windows or doors anymore.
See attached screenshots. Under the Framing section, “Header” is highlighted in red. Hover over the help and it says “Unable to find requested material”. No option to enter a value, or select anything from the drop down.
If you ty to place the window/door anyway, an error message pops up with “There are still incomplete fields”.
Not sure what to do since there is also an option to select the header material in the “normal” location.

I am having the same problem

Hi Guys, sorry I only came across this. We pay people to monitor this forum every day, so I apologise for not getting back to you earlier. :face_with_open_eyes_and_hand_over_mouth:

I assume you have your issue fixed in the updated version?
In the 24.0.0 release, some values were not filled in by default or had been changed in previous drawings by the end user. When we made some improvements, some of the tools needed either a new EG transom height value or a size. You will notice if you click through the drop-downs that one or several of the fields are red and require a value/ dimension before it will draw the window or door.

Does this solve your problem? if not, can you send us a model or attach one here?

Hi Ken, did you get your issue solved?

Andrew, thanks for the reply I’m still having an issue so I’m glad to hear from you.

I did just update today to the 24.1 release and I still can’t figure out what is going on.

In a test drawing I drew 2 walls of different types. In the wall construction window nothing is red and a value is entered for the header height. Next, I attempt to add a window or door. In this window the framing drop down is red. When I open the framing drop down, “Header” is red. The dialog will not let me enter a value or choose anything for this field. At this point Plusspec will not draw the door or window in the wall because of this missing red “Header” field.

Thank you!

Thanks for adding more detail Matt.
Matt the update went live just after 3pm yesterday, you’ll notice it come through on the welcome screen when you open Sketchup.
Looking at your screenshot it apears as though your material library needs to sync. :sync_tool: this can take 2 to 5 minutes.
I would also recommend clicking on extensions at the top of Sketchup, go down to PlusSpec and selecting factory reset.
Just make sure you only have one instance of Sketchup running when you update and sync. When finished close & reopen Sketchup.
I’m about to fly out to Japan for some architect training so @Grant will keep an eye out for a response. You can call the office +61 2 96792429 if you get stuck during business hours.

AWESOME! I used the Sync tool and that solved the problem. I didn’t think to try that because the opening welcome screen said my material library was up to date.

Happy days! Glad I can use the window/door tool again!

Thanks again!

2 Likes Matt, there’s an update out today.