Troubles after one week

Hi there !

Last saturday I decided to test Plusspec (v21.4). It was until the wall tool didn’t work at all. Finally I reinstalled everything after erasing all plusspec files and it worked until today.

I think I have a problem with Framing, because this problem came when I changed some parameters of Stud Timber and when I created a new material.
So I decided to erase everything, like the first time, but with the new version v21.6. I also tried to restore factory default, but nothing better.
Still stuck !!

All other tools works perfectly

Any idea ?

For information :
Sketchup Pro 21 Version 21.1.331
Plusspec v21.6.0 stable
Debug file :
{“sketchup”:“21.1.331”,“plusspec”:“v21.6.0-stable”,“extensions”:[{“name”:“TNT_ClickChange”,“version”:“1.1”,“author”:“David”,“loaded”:false,“load_on_start”:false},{“name”:“PlusSpec”,“version”:“v21.6.0-stable”,“author”:“RubySketch”,“loaded”:true,“load_on_start”:true},{“name”:“Outils de caméra avancés”,“version”:“1.3.4”,“author”:“SketchUp”,“loaded”:true,“load_on_start”:true},{“name”:“Composants dynamiques”,“version”:“1.8.1”,“author”:“SketchUp”,“loaded”:true,“load_on_start”:true},{“name”:“Outils Bac à sable”,“version”:“2.3.1”,“author”:“SketchUp”,“loaded”:true,“load_on_start”:true},{“name”:“Trimble Connect”,“version”:“2.0.8”,“author”:“SketchUp”,“loaded”:true,“load_on_start”:true}],“environ”:{“USER”:“fctm”,“PATH”:“/usr/bin:/bin:/usr/sbin:/sbin”,“LOGNAME”:“fctm”,“SSH_AUTH_SOCK”:“/private/tmp/”,“HOME”:“/Users/fctm”,“SHELL”:“/bin/zsh”,“__CF_USER_TEXT_ENCODING”:“0x1F5:0x0:0x1”,“TMPDIR”:“/var/folders/l1/8jw1g_112j95nbmn3thrt7tw0000gn/T/”,“XPC_SERVICE_NAME”:“com.sketchup.SketchUp.2021.13868”,“XPC_FLAGS”:“0x0”,“IG_ROOT”:“/Applications/SketchUp 2021/”,“GEM_PATH”:“/Users/fctm/Library/Application Support/SketchUp 2021/SketchUp/Gems”,“GEM_HOME”:“/Users/fctm/Library/Application Support/SketchUp 2021/SketchUp/Gems”,“SSL_CERT_FILE”:“/Applications/SketchUp 2021/”,“RLM_DIAGNOSTICS”:“/Users/fctm/Library/Application Support/SketchUp 2021/liclog.txt”,“RLM_ROAM”:“”,“SQLITE_EXEMPT_PATH_FROM_VNODE_GUARDS”:“/Users/fctm/Library/WebKit/Databases”},“ruby”:“2.7.2”,“now”:“2021-11-27T16:26:33+01:00”,“useragent”:“Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) SketchUp Pro/21.1 (Mac) (Mac; Safari)”}

Capture d’écran 2021-11-27 à 16.28.01.jpg

Another things about the wall tool.

If I enter a new dimension for Height or Header Height, I have no return if I use a point 2.74 or a comma 2,74. With the slab tool or any else, the orange color becomes red if I enter a point.

I’m really stuck with this wall issue…

I tried some manipulations :

  • full erased of Plusspec
  • full erased of Sketchup

The same problem comes again and again.
All tools work well I think, but not the wall one.

Some help will be great !


Thank you for your detailed explanation of the issues you are experiencing, sorry it hasn’t been a smooth start!

I will have to come back to you on why this might be happening. I can see you are based internationally and we have previously come across problems with default computer settings with internationally programmed devices.

We appreciate all your efforts and patience, getting onto this now!



Good News! I believe we’ve figured out the problem comes down to what the definition of a decimal is on your device. For some Mac’s, a decimal point is recognised as a comma, not a full stop/point

Here is an article on how to change this on a Mac: … in%20Excel.

Give this a try and let me know how you go!