Slab Help

I posted this in the newbie section but I havent had a response and I really need to get it fixed. Im a uni student and its for an assignment that is due in a few days.
What did I do to my model that makes the slab no longer be recongised as a slab.

What I mean is - I have a room that is supposed to be a ramp going down to the basement car park so I want to make a void in my slab. I have watched the tutorials and it just says “right click on the slab → choose slab → choose void tools” type of thing

but when I do that it doesnt give me those options

For example if I click on a wall and do that - I get the wall options Wall.png

but if I click on the slab I dont get it Slab.png

I was going to upload my model but its too big so it wouldnt let me do it.

This frustrating the hell out of me because I only need to make 1 void and 1 recess (for the liftwell) but I cant do either because my slab is no longer a slab.

Any advice on what I did and also how I can tell plusspec that its still a slab would be greatly appreciated.


Hey Jay,

If you just check your first post I have responded



There’s definitely an issue here. I just tried to create a slab w/o footings etc (other) see upload, it shows the result. Creating a void works only if you create a regular slab (footings etc, given a dimension) but when you create a slab only, voids do not execute.


Slab Void tool issues.skp (541 KB)

Ah Interesting, thanks for raising the issue again Ian. I took a look at your model and I can see the problem now.

I will send this over to the development team to see what’s going amiss!

Thanks for picking up on the error guys!

Hi Ian,

We’ve figured out what’s happening here!

So to add a void into a slab with no footing, you’re going to want to tick the “Thickness Only” tickbox in the slab tool.

There seems to be a bit of an issue in the tool where you aren’t able to edit an existing slab to become “thickness only” which we’ll have to fix, so you’ll have to redraw the slab which is easy enough to do, but still not right.

One other problem with the tool is that you always need a specified dimension in the Footing Width and Footing Depth fields in the slab tool otherwise the thickness only option won’t work. We’ll also have to fix this.

Once the thickness only box is ticked it won’t matter, so even if you just add 1mm depth and width and then tick the thickness only checkbox it will work.

Thanks for picking up on this issue! If there are any further Items you wish to add just let me know.

Happy Modelling!


Emily I’ve uncovered another issue when trying to run the takeoff tool. Here’s the error message.
Slab Takeoff Screen Shot.png

Hi Ian,

Yes, we’ve been madly fixing this bug over the last few days and we’ve got it all sorted now. You can download the update with the fix here:

Best regards,