PDF Import Does not work

Hi everyone,

My PDF Import tool has stopped working. I am using the latest PlusDesignBuild, but nothing happens when I click on the ‘PDF Import’ icon. The pop-up tab/screen does not open. I have tried resetting the workspace, changing the resolution, and using a different monitor, but nothing has worked. It’s still stuck.

How can I fix this?

Thank you.

Hi user32,

I’m not able to replicate the issue but it is very odd. Does a message come up in the Ruby Console when you try to open the tool? If it does, can you please copy the code & send it across? To do this, go to Extensions > Developer > Ruby Console & open the tool.

We’ve also just release a new version (v24.4) so I’d also recommend installing this version & see if it fixes the issue.

Hi Grant,

Its stuck somewhere in the back end, it was working fine, but few days ago i kept importing some plans and then it just stopped popping up, now nothing happens when i click on PDF icon.
Nothing comes to Ruby Console.

It’s annoying not being able to use it.

Hi user32,

Another possibility is that the dialog is opening but appearing somewhere off the screen for some reason. If you follow the below steps & it should fix the issue.

  1. Close all running Sketchup windows.
  2. In a File Explorer, enter %LocalAppData% in the address bar at the top (see image below for more details).
  3. Follow the path below & delete the file highlighted in bold.
    SketchUp → SketchUp 2024 → SketchUp → PrivatePreferences.json
  4. Start Sketchup & open the PDF Tool.

That was the problem, i can see it now…

Thank you Grant, good to have you here.

Are you using PC or Mac? @Grant

I’m using Windows (PC), I haven’t come across this issue on Mac yet.