material alignment & split walls

Material Alignment
when splitting walls sometimes the material doesn’t align. I remember that at some stage this was able to be done in a couple of easy steps. Could you please remind me how to do this.
Split Walls
when slitting walls there is a line left and this shows up in layout. Can this be “turned off” so that you have a wall without any lines

Did you turn the layer off? (Hidden wall edges) Is view hidden geometry selected?
If you are using 2 different wall types the line should show. Can you add a screenshot so I can help more?

layer is off
plusspec support.JPG