License activation limit exceeded

Hi There

I’m trying to run your trial but I got the error - license activation limit exceeded on the first machine I tried to activate on. Please advise. I also should mention that I tried to use your support forms but they wouldn’t submit on chrome (didn’t try other browsers). As a result I’m posting here.


Friendly Ping… Any body home? I’d love to be able to use plusspec.

A bit more info… I checked my subscription page and I see “We are processing your order. Please wait a few minutes and refresh the browser”. Please let me know if I need to resubmit my payment information.


very sorry about making you wait for a reply.

We have noticed that you have signed up with but you have not purchased a license.

Normally your payment should come through straight away or it will say that your payment has been rejected because of a certain reason. Please try again and email me with any further problems:

We can’t wait to have you up and running with PlusSpec and I will do my best to help.

Kind Regards