Importing from Ruby Sketch

Hi Guys,

I am finding when i am importing components (ie bath) from Ruby sketch into plusspec that when i send this through to Layout the items arent clearly defined in 2d on plan. Is there a way to make them show better?

The other question i have is that if i import something from Ruby sketc, then copy it within Plusspec (ie CTRL C CTRL V) will plusspec quantify the copies? Ie if i only drag one toilet accross from Ruby Sketch and copy it 5 times will plusspec quantify that, or do i need to drag it from Ruby sketch each time?



Hi Jacket007,

Could I ask which models from Rubysketch that you were using? and was it all the models or just a few that weren’t displaying correctly ?

If you go to SketchUp model on the right side of layout you will see a drop down box that will say either raster, vector or hybrid. These are different types of quality for your plan. Vector is the best for lines and would be my pick for better model quality. Try this and let me know what you think.
Another way to add a bathroom layout is to self draw a quick bathroom layout inside of layout or even trace over the models if you aren’t happy with the display.

In reply to your other question, yes if you copy a model in side SketchUp it will quantify all 5 copies plus the original and say (ie Quantity 6 - name: Britex Toilet suite). Im not sure if you know this but this is a handy and quick tip, instead of using CTRL C and CTRL V. Click on the move tool and then click on your model that you wish to copy and you will notice that the model will move around but then press CTRL on your keyboard and you will notice that the original model will return to it’s original place and you will have a copy of the model that you can place where ever. Once placed down without clicking anything else type this (*6) without the brackets and you will notice there will be six copies plus the original that can all be moved around, this saves time and can be really handy with other areas of SketchUp.

Kind Regards

Hi Dean,

Upon further inspection it appears that only models with soft edges (eg rounded off edges) such as bathtubs have trouble showing really clear detail.

I have been tracing around it simply to clarfiy, that seems to fix the problem.



Try enabling profiles (in the style options) if you haven’t already. This will make sure there is always an “outline”, even if using soft edges.

If you don’t like the appearance of the profiles, you can set them to be the same size as the edge (by setting the value to 1) and they shouldn’t be as noticeable.

I usually don’t show profiles, but when dealing with curve extrusions with soften surfaces then profiles can really help.
What maybe helpful is to create a template with two styles, one with profiles OFF and the other with profiles ON (with profile value of 1), then with different views you can easily toggle the profiles on and off for comparison.

To emphasize this, the attached model uses the Hidden Line style active for all scenes.

If the model is sent to LayOut, then you can “amplify” the visible edges and profiles via the Line Weight option (see attached image files).
This seems to work best when in RASTER display mode.

The attached .skp was created in SU2014.

Toggle Profile On Off.skp (345 KB)


Toggle Profile On Off.skp (345 KB)
Toggle Profile On Off - VIEW, SCENE..JPG

Toggle Profile On Off - Profile OFF side view.JPG

Toggle Profile On Off - Profile OFF top view.JPG