Floor offset from selected face

What will cause the joist tool to not construct the desired floor structure in the location of the selected face?

I have been able to draw a small face (see attached which is separate to the building) and then selected it and as per normal it has created the created floor. No probs!

Every time i try to the floor on the selected face adjacent to the building it always offsets it as per the attached.

I had a floor in the correct position but needed to change the joist size, so i deleted the old floor and now every time i try to recreate it, it is offset from the face selected.

I realise i could move the offset floor to the correct position but there is also no decking showing, yet it is selected.

i have deleted the face and redrawn it. still the same result

Any help appreciated.

Hi Max,

Thank you for your post.

I tried to replicate the issue by drawing a shape similar to the one in your attachment but couldn’t get an issue to appear.

Would you be able to please send the model across to support@rubysketch.com so I look into it further?

HI Grant,

I have found a solution, where by I re drew the shape separately and the moved it back to the correct place. I have updated the model beyond a point where i can send it thru for you to look into it further.
it was quite a strange anomaly, something which I seem to be good at finding. If it re occurs i will forward to you.

Thanks anyhow.

Hi Max,

I’m happy to hear that you were able to find a solution.

Please let me know if you come across this issue again.