Hi team,

I have noticed that the estimation tool keeps not saving data. For instance, I complete the wastage box, and then I use the save function in the main SketchUp tab. I open the model and go back to the estimate; the wastage is no longer there. This happens on other line items, also. On the crees shot, the markup profit is no longer there, but this was filled out. The same with the vendor; this disappears also.

Screenshot 2023-09-25 155703.png

Is the BIM component tool only designed to record an instance of an object rather than quantify the parametric attributes.

As an example, I drew a footing of irregular shape thinking I could BIM it, and then draw multiple lengths of this footing and be provided with the quantities. But I could only get ‘one’ instance in the quantification not any volume or length.

How do I create parametric objects that will quantify similar to the wall tool?

Thank you, Gareth

Hi Gareth,

Thank you for your enquiry.

I tested the latest version of PlusSpec but I wasn’t able to replicate the issue(s) as the values were saving for me. Note: Those values should be automatically saved once you click out of the field.
What I would recommend doing is to go through the following checklist & see if they fix the issue. If the issue still occurs we’ll need to schedule a time to log into your computer to try to diagnose the issue.

  1. Make sure the latest version of PlusSpec is installed.
  2. Make sure the latest version of SketchUp is installed.
  3. Restore PlusSpec’s default settings. To do this, go to ‘Extensions > PlusSpec > Restore Factory Default’.
  4. Check if an error message appears in the Ruby Console when the takeoff is launched. If a message appears please send it to us (important: please copy & paste the whole message).

By default, the BIM Tool will set the objects to be estimated as each. To change this select the desired estimation type from the UOM field (shown in the image below), then enter the size of the object (it doesn’t automatically read the size) & submit the changes. If these options don’t appear for you please download & install the latest version of PlusSpec.

BIM Tool UOM Types.png

Yes these items I already checked, so its not really moving me forward.

As for the BIM items, I also have been using the UOM as linear, but this does not calculate a length. It appears from the explanation that I need to type in the total length of something drawn? I had assumed if I drew an item 1m in length then “stretched” that item to 10m in length the BIM object would now show 10m. Is this not the case? Are you saying I then need to manually type in 10m of length? What about volume or other attributes?