Editing existing window or door on MAC causes hang


Firstly I have been using PlusSpec for a few days now, PlusSpec feels like it has so much potential, and I am very impressed with everything that is working for me.
BUT a major issue is affecting my experience.

If i try to edit an existing window or door, to change the header height or a material or whatever, after pressing submit the computer hangs for a very long time, possibly forever !
The only solution currently is to delete the window or door, and recreate with the desired settings so that i avoid the hang.

In a simple test case of one wall (external clad), one door (tried a few different ones), and one window (louvre, sliding, i could try others) . the computer hangs for 2-3 minutes. for 30+ windows the longest i have waited before forcing the application to quit was 15 minutes.

So naturally one wonders why is this happening to my installation and not others.
Here’s my setup:

  • PlusSpec is only extension installed
  • 2.4 GHz Intel Core i7
  • 16GB Ram
  • AMD Radeon HD 6770M 1024 MB
  • MAC, OSX 10.10.5 (Yosemite),
  • Sketchup Pro 2015. 15.3.329
  • PlusSpec up to date as of this post

This problem was first brought up in the post: ‘Louvre windows not cutting wall when i copy them’ https://plusspec.com/forum/viewtopic.php?f=12&t=511
Other possibly unrelated symptoms are:

  • 3D mouse stops responding often after the use of a PlusSpec tool such as window or door, and after it starts again it is not smooth motion (whereas it is smooth before using a tool)
  • Louvre window component attributes is missing fields

It is essentially a show stopper for me.
A client just asked me whether we could change the thickness of some windows and the colour. I had to say no because the software was playing up and there are 40 windows! Naturally there is a bit of disappointment going on around my office.

Can anyone confirm similar symptoms?
Is this MAC OSX related ?


I have been looking into this for you over the last couple of days.

Your computer setup should have no problems. I have never heard of this before, the main part that I find could conflict with the tool is the 3D mouse. If you could tell me exactly what 3d mouse model you are using I can do some research on it. It could be that the 3d mouse is conflicting with SketchUp. Have you tried using PlusSpec with a normal mouse?

Very sorry that you are having this issue. I am going to get ready a BETA version for you to test. Please send me an email if you are interest in testing a BETA version.

Email - dean@rubysketch.com

I will do my absolute best to help you get past this. I can understand that it is disruptive and annoying.

Does this happen for any other tool?

Kind Regards

Hi Dean,
my 3D mouse is a ‘3dconnexion Space Mouse’ which is truly an invaluable piece of hardware for 3D navigation. I simultaneously also use a normal mouse as well.
At first i thought it was just to do with the louvre window, then i realised it was every window and door i have tried so far.
I’ll do some more tests and get back to you tomorrow.
Also I sent you an email.

Hi Dean,

I tried unplugging the space mouse and still have the same issue with a single wall and 1 window.

I’m thinking of reinstalling both Sketchup and PlusSpec and Spacemouse driver, any advice or request as to how i go about this ?
There is an update for space mouse driver i will try first v10.2.4 ! (i’d want to update that anyway)
Will i have issues reinstalling my PlusSpec license ?

My plan is:

  1. update space mouse driver
  2. test
  3. copy all relevant directories containing my settings, templates, license, plugins, etc and then DELETE them
  • /Users/user/Library/Application\ Support/SketchUp\ 2015
  • /Library/Application\ Support/SketchUp\ 2015/SketchUp
  • /Users/user/Library/Application\ Support/rubysketch
  • ?
  1. remove Sketcup application /Applications/SketchUp\ 2015 by dragging to trash
  2. re-download Sketchup Pro and re-install
  3. test Sketchup with new spacemouse driver again
  4. re-download PlusSpec and install
  5. test and have success :slight_smile:
  6. selectively copy back previously copied backups, with tests as i go

Here’s more detailed specs of current setup:

  • PlusSpec is only extension installed
  • 2.4 GHz Intel Core i7
  • 16GB Ram
  • AMD Radeon HD 6770M 1024 MB
  • MAC, OSX 10.10.5 (Yosemite),
  • Sketchup Pro 2015. 15.3.329
  • PlusSpec up to date as of this post
  • 3DxWare 10 v10.2.1 (spacemouse driver for OS)
  • SpaceMouse Wireless firmware 4.38

Any advice is appreciated

Further tests before updating reinstalling anything

draw wall, add window, select tool (to get out of plusspec tool), context click wall → edit door, submit, HANG
draw wall, add door, select tool (to get out of plusspec tool), context click wall → edit door, submit, HANG
draw post, select tool, context click → edit post, submit, OK
draw slab, select tool, context click → edit slab, submit, OK
draw face, make roof, context click → edit roof, submit, OK

Hi John,

We are still looking into this. Thank you for your support and patience.

If you do have another computer available (preferable quite similar) try download and install PlusSpec onto it and use the same mouse and keyboard and any other attachments. then try without any of them, if the error only occurs when attachments are plugged in then it is one of them.

Thank you so much for giving us so much information and working with us to get this sorted. We will get down to the bottom of this.

Is anyone else having the same or a similar problem?

Kind Regards

i’m currently testing on a similar (not identical computer)
incrementally installing hardware

Thank you for the update.

Please keep us updated with your results. :slight_smile:

Kind Regards

Ok all good so far on computer 2
I have tested with simple scenarios as outlined above, and with a complex model that was not working before.
So i think it is time for the annual system clean install for mine and see how that goes.

Computer 2:
2.3 GHz Intel Core i7
4GB Ram
Intel HD Graphics 4000 1024 MB
MAC, OSX 10.10.2 (Yosemite),
Sketchup Pro 2015. 15.3.329
PlusSpec up to date as of this post
3DxWare 10 v10.2.4 (spacemouse driver for OS)
SpaceMouse Wireless firmware 4.38
Sketchup Extensions

  • PlusSpec
  • /Library/Application\ Support/SketchUp\ 2015/SketchUp/Plugins/3DxSketchUp.rb (3d mouse driver)
  • Dynamic Components

Still working fine on computer 2, I haven’t got back to computer 1 yet.
Loving PlusSpec

Thanks John,

Great to hear. Your model is looking great from the email, keep the great work up! :slight_smile:

Let us know how you go with your first computer.

Thank you again for your co-operation and your patience.

Kind Regards

I have reinstalled my system and the hang no longer exists. OSX 10.5.5
(I’m in no rush to update to 10.11 just yet on my production machine)
It is a complete mystery as to why plusspec in particular was having troubles.

Hi John,

Great to hear that it is all sorted :slight_smile:

Kind Regards

So this problem reappeared. I have been in correspondence directly with developers but am not getting any where. I am waiting for some help to debug.

Hi John,

We are still trying to replicate and work on your error as you are aware this is the first time we have seen an issue like this before.

Kind Regards

Well the plot thickens… I have just installed windows 10 on my macbook pro using boot camp.

The same thing is happening in Windows !!!
There is very long delays when editng certain windows.
which is leading me to wonder if is related to the graphics card ??

AMD Radeon HD 6700M

It is so strange that for all other intents and purposes my computer works fine for everything else, except this area of PlusSpec.
So frustrating soooo weird

In windows i am occasionaly getting the following error when there is a very long lag

“CFileException 3 in \Mac\Home\Documents\AutoSave_Untitled-0.tmp”

Hi John,

I am going to send you a test version today that I think has fixed your issue. I can not be 100% sure but it is worth a shot.

It may be due to running a parallels system. Yes you are correct this is very weird.

It may be due to your graphics card. I would assume that if you are running parallels that you would be running a higher graphics card but I am unsure of that.

I will have a developer look at this tomorrow. You will receive an email from myself with a version to test.

Kind Regards

As has been discussed with PlusSpec via direct email. This issue is still a MAJOR problem for me.
The system was reinstalled and problem persists.
I need to know that either my system is not supported or get this to work.

I have updated to latest sketchup and plusspec, and am still haunted by this crippling loss of functionality (the ability to edit a window or door)
Sketchup 16.1.1451
PlusSpec v16.2.1

It really seems like the only way to resolve this is purchasing another computer as it seems i am the only user experiencing this issue.