Edit window/door problem ... still

Hi There,

I have been looking forward to this new version and the changes to the window and door tools, hoping it would solve my window editing problem. But now not only is it still doing it (it was only an issue in in one of the edit windows previously), now I can’t change anything as causes SketchUp hang. So I’ve just resorted to deleting the window and redoing it every time there is a change. Time consuming and tedious!

I have found it all to be a bit laggy. When I start moving windows, editing walls, it takes quite a while for the system to catch back up. I don’t think this is the computer not keeping up.

We haven’t solved this yet, but maybe there’s always hope…



Hi Dawson,

Thank you for your email.

Would you be able to please let me know if this still happens if you install the latest version (v18.3)?

Also, if you have ‘Outliner’ open or active in SketchUp I’d recommend to close it until it’s needed as this will cause some lag when editing walls and windows & doors.

Hi Grant,

No, it still happens. And no, I don’t have outliner open. never have really.


Hi again,

I just thought I'd touch on this again.  Is anyone else having this problem?  I find the whole things is getting clogged up somehow. After some time of doing what should be expected: editing walls, moving windows, updating, the whole operation starts getting slow and laggy. This is without editing windows or doors as I know that's a problem, for me anyway. I can only do one and then have to restart SketchUp.  As I see it this is what we are paying for here, but it doesn't seem to be keeping up. This is new (not the window and door part) since the new version. What's changed for the slower?



Dawson, I also have this problem. No matter what I edit, it hangs. Outliner is not in tray. Running latest version of SU and Plusspec.

Greetings! Well, after a couple years now of trying to figure it out, and with the PlusSpec team with me to help, it seems to have resolved itself! I don’t know what’s different, but it seems good now. I’ll post more if it changes.

Here’s hoping it stays good! And good luck to you Sketchhouse, Wish I could advise you as to what might help. Maybe get them to help figure it out, and it will fix itself…


Hi Dawson and SketchHouse,

It seems to me as the window lag problem could be a conflict between other plugins as we rarely hear this issue. The best way to deal with is to turn the other plugins off one by one and test the speed. If you find this rectifies the issue let us know which plugin was conflicting and we will try to talk with the developer and rectify.

Thanks for commenting.

I would be interested to know if this fixed your problem? I have not encountered this issue so if you found that a Plugin was interfering with the efficiency of the drawing please let us know as it is probably something easily fixed.

Hi there, just updating. This lag issue has not actually resolved. It is somewhat (though not very) intermittent. I have tried turning off plugins and it doesn’t seem to make a difference. Even with the clean new install of sketchup 2019, no difference. It is a bother, but I have been just working around it.

It will be fixed now Dawson, I have heard a 100% strike rate so far, please don’t prove me wrong. If you are getting the issue I would try on another computer because it sounds hardware related ( I had a similar problem with an I7 high-end laptop from day one, I took it back, and the new one worked fine, go figure). BTW if you have a lot of windows in on wall you will find lag when amending, so a workaround is to split the wall to minimise the amount going at once. It is easy to meld the wall later.

Hi Andrew,

Not yet I'm afraid.  I don't have another computer to try it on, but I don't imagine that I'll replace the computer because I can't redefine my windows in PlusSpec.  It just seems strange that It doesn't affect anything else, in SU, out of SU, even in PlusSpec.  The handrail tool also bugs when edited.

I had a video conference with Tyler Moeke and it wouldn't do it at all.  That was the real kicker. But it's been doing it ever since.

Puzzling, and time consuming…

Here’s hoping something clears it up!


Hi Dawson,

I’m not sure what’s happening here. I’ve tried to replicate the lag issue on multiple computers (both on Window & Mac computers) without any success and we’ve tried to diagnose what the issue could be but got the same result. There are a few more things I would recommend trying and see if they fix the issue. I’ve listed these below.

  • Restart your computer. If it hasn’t been shut down in a while it may need to be restarted to refresh the system.
  • Reinstall Dynamic Components. In SketchUp 18 they made changes to Dynamic Components which may help fix this issue (it may also fix the Handrail Tool error I believe you’ve been having as well). To do this in SketchUp 18 & 19, go to ‘Window > Extension Manager’ and in the ‘Manage’ tab click the update button to update this extension. If you aren’t able to you should be using the latest version.
  • If you aren’t already, update to the latest version of PlusSPec (v19.0). There were performance changes in this version which make the dialogs throughout PlusSpec open quicker.

If the above doesn’t fix the issue, I’ve got a few questions which will hopefully help in diagnosing the error.

  1. When does the lag happen? When the dialog is opened or when the changes are made (i.e. after Submit is pressed)?
  2. How long is the lag (i.e. a few seconds, more than 10 seconds)?
  3. Does the lag happen for every window or just specific ones?
  4. Is the lag only when editing a window or door using the Edit Window/Door Tool or does it happen for the other window & door tools as well?

Please let me know how you go with the above recommendations.

HI fellows,

Here are some responses to those ideas:

I shut it down every day…
I seem to be up t date with Dynamic Components
Up to date with Sketchup.

As soon as I’ve edited any window or door (after pressing submit), the entity info freezes the window that was edited. I can actually keep working for a while, but the entity info window won’t respond. Any attempt to edit another door or window will result in the dialogue trying to come up, but not getting there. I usually close it after a while. Eventually Sketch Up will crash. I can redefine windows, or delete them, or make new ones with no problem. It’s just the editing part that causes problems, and the same with the handrail.