Doors and windows function is not working


I am running sketchup 2018 on my mac from India. I had come across plusspec from a youtube tutorial. i immediately signed up for it and downloaded the trial version. It has the potential for being an intelligent plugin. After installing, I was going through the tutorials provided by the software. All the tools were working properly while I was completing the tutorials.

Once I was finished with the tutorial, I was trying to draft a small house to test the software. During this process, I had finished drawing the wall and I was about to place the doors and windows. While I was trying to place doors, it repeatedly pops up a dialog box asking for incomplete fields. The same was happening with the windows function as well.
Let me know if this could be solved.

Hi shriramjuttu,

Thank you for your post & my apologies in the delayed response.

This normally happens when the model/dialog units are different from the default units set for each country material library. This means that if you have the USA material library installed (which is imperial) but your model/dialog units are metric then this kind of issue may appear.

Please follow the steps below as they should fix the issue.

  1. Go to ‘Window > Model Units’ & make sure you . Note: This can also be selected when selecting a template when SketchUp is launched.
  2. Go to ‘Extensions > PlusSpec > Settings’ & make sure you have the correct material library installed (currently there is only AUS, USA & UK so you must pick from these).
  3. In the same dialog (Settings Tool), make sure the Dialog Units are set to the correct option according to whether your model units are imperial or metric (i.e. metric = AUS or UK, imperial = USA). Note: By default this will be set to use the model units which were set in Step 1.
  4. Go to ‘Extensions > PlusSpec > Restore Factory Default’, which will return your dialog option & values to factory settings.

Would you be able to please let me know if this fixes the issue you’re having?